Peavey Mark III versterker

Zelfbouw, reparaties, afstellen en nog veel meer.
Gebruikersavatar
Soulbender
Berichten: 6128
Lid geworden op: 16 jun 2011, 18:40

Peavey Mark III versterker

Bericht door Soulbender »

Hee allemaal!

Onlangs heb ik mijn Peavey Mark III uit de berging gehaald en kwam ik erachter dat op Channel B de potmeters van Bass en High geen effect hebben.
De versterker heeft twee kanalen die beiden OF met potmeter-EQ of met Grafische EQ in te stellen zijn.

Afbeelding

Bij Channel A werken beide opties goed. De potmeters werken en als ik schakel naar de 6 bands EQ werkt ook alles goed.
Channel B heeft een Paramid shift, waarbij je kunt instellen op welke frequentie je mid potmeter reageert. Die werkt top.
Enkel, de Bass en High potmeters werken niet. Wanneer ik overschakel op de 6bands EQ werkt het goed, maar blijft de Paramid-potmeter effect hebben.

Ik weet niet of dat de bedoeling is, maar het lijkt mij van niet aangezien ik ben overgeschakeld op de 6bands grafische EQ.
Dat de Bass en High niets doen hoort sowieso niet te zijn. Die doen ook niets als ik over beiden kanalen tegelijk speel.


Ik heb de amp al opengehaald en met contactspray de potmeters doorgespoeld en losgedraaid. Ook de switch waarmee je van Grafische EQ naar de potmeters schakelt heb ik schoongespoten.
Verder heb ik de potmeters en de switch doorgemeten en die lijken gewoon goed te zijn. De potmeters geven beiden 3.4 aan wanneer ze volledig openstaan en de switch lijkt qua continuiteit ook te werken.

Heeft iemand misschien een idee wat er aan de hand is en waar ik nog meer naar kan kijken?
Ik heb er zelf niet perse verstand van maar ben nieuwsgierig genoeg om er zelf even naar te neuzen.

Foto's van de binnenkant zal ik morgen maken, als ik wat beter licht heb.
Maar misschien heeft iemand al een idee?

Thanks! :mrgreen:
Plaats reactie